Skip to content

Eclipse Toolbar unter KDE verschwunden

Ist ja wie immer, sobald es eilig wird, kommen merkwürdige Dinge. So auch, dass nach dem zweiten mal Starten von Eclipse Neon, die Toolbar nicht mehr vollständig zu sehen war. Insbesondere im Debug-Modus fehlten alle Toolsbaricons und die Perspektive war auch nicht mehr über Toolbar umschaltbar.
Wenn man nun im Internet sucht, findet man viele Hinweise. GTK ist halt nicht der Hauptanzeigemanager bei KDE und das muss man Eclipse erst mal klar machen.
Bevor man also Eclipse startet:

- ggf. alle Konfigurationen von GTK entfernen
rm -rf $HOME/.config/gtk-*

- Eclipse davon abhalten zu glauben, dass es ein normales Ubuntu ist
export UBUNTU_MENUPROXY=0

- Eclipse davon abhalten zu glauben, dass es GTK-3 gibt
export SWT_GTK3=0


Nun kann ich wieder Eclipse verwenden.

Personalisierte Werbung

Heute ist mir ein bestes Beispiel für eine personalisierte Werbung aufgefallen. Trotz Adblocker hat google diese bei Youtube untergebracht.



Ein verknapptes Angebot für eine Gleitsichtbrille, speziell für über 45-jährige.
Wie macht google das?
Google kennt Fotos von mir mit und ohne Brille. google weiß, dass ich mal nach Brillen gesucht habe. Google kennt mein Alter.
Klicke ich auf das Angebot, lande ich bei brillen.de . Da ist aber dann keine Rede mehr davon, dass es eine Bedingung gibt.
Die gab es nur, um mich interessanter zu machen, damit ich besser auf die Verlockung eingehe.
Schaue ich mir mal den Preis an. Von 1000,- € auf 249,- €. Das ist aber ein satter Rabatt. Gucke ich mal bei der Konkurrenz nach. Da gibt es Gleitsichtbrille schon ab 149,- € .
Das riecht für mich nach unlauteren Wettbewerb. Da hier aber "nur" der Verbraucher betroffen ist, gibt es wohl keine Gefahr für diese Machenschaften.

Was kann man dagegen tun?
1.) Lernen, dass man ständig manipuliert wird, um etwas zu kaufen und entsprechend vorsichtiger sein.
2.) Nicht mehr AddBlockerPlus verwenden. Meine Empfehlung momentan ist uBlock.
3.) Do not Track me verstehen und aktivieren. Aber es kann sein, dass man dann nicht mehr in den Genuss von Mainstream-Journalismus kommt. Also zwei mal gewonnen ;-)

Fehler mit ld.so.preload nach Installation von ESET NOD32 Antivirus

Es gibt tatsächlich ein kommerziellen Anbieter eines Antivirenprogramms für Linux. ESET bietet nun auch ein attraktives Lizenzmodell an, dass die Absicherung von verschiedensten Maschinen erlaubt. Dieses habe ich genutzt und unter Windows und Android keinerlei Probleme bei der Installation gehabt. Allerdings unter Linux:

Nach der Installation tauchten bei jedem Ausführen eines beliebigen Programms Fehler auf, die ein Problem mit ld.so.preload hatten. Und zwar wurde dort auf eine 32 Bit Variante ihres libesets_pac.so* verwiesen. Ich habe aber ein 64 Bit System

Zur Umgehung habe ich folgenden Workaround vorgenommen, ohne dass der Schutz reduziert wird:

1.) Umbenennung der 32 Bit Bibliothek:
mv /opt/eset/esets/lib32/libesets_pac.so auf opt/eset/esets/lib32/libesets_pac32.so

2.) Lösches des Links unter /usr/lib und neu hinzufügen auf die umbenannte Datei
rm /usr/lib/libesets_pac.so
ln -s /opt/eset/esets/lib32/libesets_pac32.so
/usr/lib/libesets_pac32.so

3.) den vollen Pfad in der Datei /etc/ld.so.preload angeben mit /usr/lib64/libesets_pac.so

Spätestens nach einem Neustart wird die 64-Bit Variante ganz sicher geladen, weil die 32 Bit Variante nicht mehr unter dem selben Namen verfügbar ist.

Achtung: Wenn man /etc/ld.so.preload einfach wieder löscht, dann sind auch keine Fehler mehr, aber es gibt keinen Schutz mehr (getestet mit http://www.eicar.org/85-0-Download.html), obwohl ESET NOD32 Antivirus dies behauptet.

virtuelles Linux System für Homebanking - aber Vorsicht mit der MTU

Kurz mal ein Problem berichten, dass ich dann doch lösen konnte.
Seit einigen Tagen konnte ich nicht mehr mit meinem virtuellen Linux Debian System Onlinebanking machen. Weder mit der Finazsoftware(FS) Moneyplex noch mit dem Browser.
keine http(s) Verbindung zum Bankserver möglich
kam immer bei der FS. Im Browser (Firefox und Chromium) war das Verhalten noch merkwürdiger. Einloggen funktionierte, auch einige Klicks funktionierten, sobald man aber auf wichtige Weiter Buttons klickte, wurde die Seite leicht dunkler und es passierte nichts mehr. Da dachte ich natürlich zunächst, dass die Postbank ein Problem hatte und ich habe mal per Twitter gefragt. Es kam sogar eine Antwort von der Postbank. Letztendlich sollte ich das Kundenberatungscenter anrufen. Die konnten mir leider auch nicht weiter helfen.
Linux wird leider nicht unterstützt!
Auch alle Tipps wie Cache löschen, nicht direkt einloggen usw. haben nicht funktioniert. Ich wollte schon die Bank wechseln.
Doch dann viel es mir wie Schuppen von den Augen.
Ich hatte vorher beim Hostsystem (auch ein Linux) ein bisschen mit der MTU der Netzwerkkarte experimentiert (1400 bytes) und nicht mehr auf Automatisch stehen. Beim Gastsystem (nur fürs Homebanking und Netzwerkkarte als Bridge) war aber weiterhin die MTU auf Automatisch. Das kann natürlich hin und wieder bei manchen TCP /IP Paketen zu Problemen führen. Und so war es auch. Ich habe das Hostsystem auch wieder auf Automatisch gestellt und schon funktionierte wieder das Onlinebanking.